Prova inserimento foto x Paolo C.

discussioni circa il forum e circa i minerali in genere
Avatar utente
Fulvio Malfatto
Site Admin
Messaggi: 722
Iscritto il: gio 24 giu, 2004 16:32
Località: Roppolo (BI) - Italy
Contatta:

Prova inserimento foto x Paolo C.

Messaggio da Fulvio Malfatto » sab 23 set, 2017 14:43

Foto inserita per prova per verificare problemi .
foto enrico 2.jpg
Socio AMI Piemonte

Avatar utente
Fulvio Malfatto
Site Admin
Messaggi: 722
Iscritto il: gio 24 giu, 2004 16:32
Località: Roppolo (BI) - Italy
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Fulvio Malfatto » sab 23 set, 2017 20:45

Mi sono arrivate due segnalazioni a pochi giorni di distanza di difficoltà a caricare foto. In entrambi i casi mi sono fatto mandare le foto e le ho caricate senza problemi. Sto indagando ma non ho evidenza di errori e/o problemi specifici sul forum.
Sono in attesa di ricevere dagli utenti interessati le informazioni relative al tipo di browser e di sistema operativo usati, al fine di capire se sia possibile definire un punto in comune o se oppure sia qualche problema insito nel peso del totale degli allegati o a particolari tipologie di connessione Internet usata da questi specifici utenti
Infatti, come temevo fin dall'inizio, la gestione degli allegati è il tallone di Achille di questo forum e di tutti i software che lavorano in rete. Ad oggi abbiamo 37728 files allegati, tutti gestiti in una sola cartella dal software del forum attraverso un db MySQL. Da tempo ho rinunciato a fare il backup giornaliero di questa cartella, sono passato al settimanale, ed ora al mensile, data la mole di dati difficilmente gestibile con le connessioni remote.
Che fare? Non ho risposte "economiche" a questa domanda, se non raccomandare a tutti di eliminare le cose obsolete o superflue per cercare di procrastinare il più possibile il momento in cui sarà necessario alleggerire il forum. Ribadisco come il problema siano gli allegati e non i messaggi. Questi ultimi sono infatti ben 172873 ma non condizionano in modo sensibile le dimensioni totali, rappresentando solo circa il 5% del volume totale.
Socio AMI Piemonte

Avatar utente
TOSATO FABIO
Messaggi: 5789
Iscritto il: ven 13 gen, 2006 11:39
Località: via A.Cantele n.15 35129 PADOVA

Re: Prova inserimento foto x Paolo C.

Messaggio da TOSATO FABIO » mar 26 set, 2017 7:42

e' IL CASO DI ELIMINARE ALCUNI TOPIC MOLTO PESANTI PER ESEMPIO QUELLI DELLE FOTOGRAFIE DEI MINERALI?
Lascerei i topic della tecnica fotografica dove spesso le fotografie sono utili ai ragionamenti espressi
Tosato Fabio
"Il vero viaggio di scoperta non consiste nel cercare nuove terre, ma nell'avere nuovi occhi." M. Proust
Noi siamo anche quello che non siamo riusciti ad essere.
Sic transit gloria mundi.

Avatar utente
Maurizio_T
Messaggi: 2189
Iscritto il: mer 17 dic, 2008 14:46

Re: Prova inserimento foto x Paolo C.

Messaggio da Maurizio_T » mar 26 set, 2017 8:04

TOSATO FABIO ha scritto:
mar 26 set, 2017 7:42
e' IL CASO DI ELIMINARE ALCUNI TOPIC MOLTO PESANTI PER ESEMPIO QUELLI DELLE FOTOGRAFIE DEI MINERALI?
Lascerei i topic della tecnica fotografica dove spesso le fotografie sono utili ai ragionamenti espressi
Nel caso si dovesse eliminare qualcosa suggerirei di orientarsi sui topic generici, cercherei invece di lasciare le immagini dei topic tematici regionali o dei siti, in questi casi le foto hanno anche l'importante funzione di facilitare l'identificazione.

Concordo con Fabio per quelli sulla la tecnica fotografica.
"Quelli che s’innamoran di pratica senza scienzia son come ‘l nocchier ch’entra in navilio sanza timone o bussola, che mai ha certezza dove si vada" (Leonardo)

Voltaggio
Messaggi: 40
Iscritto il: lun 20 ott, 2014 12:25

Re: Prova inserimento foto x Paolo C.

Messaggio da Voltaggio » mer 27 set, 2017 18:01

Caro Fulvio,
sto facendo una prova per allegare foto fungo
Ciao
Giovanni
Allegati
IMG_4752.JPG

Avatar utente
Luca Baralis
Messaggi: 2882
Iscritto il: lun 06 set, 2004 18:55
Località: Torino
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Luca Baralis » dom 01 ott, 2017 10:15

Poco fa ho tentato senza successo di allegare qualche foto del Mineralexpo di Torino.
Luca (LB)
Socio AMI Piemonte

Avatar utente
Fulvio Malfatto
Site Admin
Messaggi: 722
Iscritto il: gio 24 giu, 2004 16:32
Località: Roppolo (BI) - Italy
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Fulvio Malfatto » dom 01 ott, 2017 20:42

Ad oggi le segnalazioni di tentativi falliti avevano in comune la versione di Window (7 a 32 bit) e l'utilizzo di versioni piuttosto vecchie dei browser.
Io ho provato da tutti i browser disponibili su Win10 e da tutti quelli disponibili da Linux e non ho mai avuto problemi. Non ho un Mac per fare prove anche da Mac OS. Per capire cosa non va sarebbe utile che mi segnalaste sempre le versioni di software che usate e soprattutto la piattaforma, visto che ormai i 32 bit sono pochissimo diffusi e non certo manutenzionati a dovere
Socio AMI Piemonte

Avatar utente
Luca Baralis
Messaggi: 2882
Iscritto il: lun 06 set, 2004 18:55
Località: Torino
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Luca Baralis » dom 01 ott, 2017 21:02

Fulvio Malfatto ha scritto:
dom 01 ott, 2017 20:42
Ad oggi le segnalazioni di tentativi falliti avevano in comune la versione di Window (7 a 32 bit) e l'utilizzo di versioni piuttosto vecchie dei browser.
Per quanto mi riguarda Ms-Windows 7 a 64 bit, al passo con gli ultimi aggiornamento Microsoft (che per altro un po' di casino lo hanno fatto!).
I browser di default è Firefox, anche questo dovrebbe essere aggiornato.

Ho provato ancora un inserimento (foto a caso) in questo stesso messaggio senza successo. Noto che nel riquadro di inserimento dati dell'immagine, a destra, sotto la voce "stato" compare un triangolo giallo con punto esclamativo; click e si svela l'errore (presunto): L’immagine deve essere larga almeno 0 pixel pixel, alta almeno 0 pixel pixel, al massimo larga 2000 pixel pixel e alta 1200 pixel pixel. L’immagine proposta è larga 3888 pixel pixel ed alta 2592 pixel pixel.
Però l'immagine in realtà dovrebbe essere di 448x299 pixel ...
Luca (LB)
Socio AMI Piemonte

Avatar utente
Luca Baralis
Messaggi: 2882
Iscritto il: lun 06 set, 2004 18:55
Località: Torino
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Luca Baralis » dom 01 ott, 2017 21:07

Ulteriore prova di inserimento, stesso SO, ma questa volta browser Chrome.
Stesso risultato, stesso messaggio di errore.
Luca (LB)
Socio AMI Piemonte

Avatar utente
Fulvio Malfatto
Site Admin
Messaggi: 722
Iscritto il: gio 24 giu, 2004 16:32
Località: Roppolo (BI) - Italy
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Fulvio Malfatto » dom 01 ott, 2017 21:09

Per favore, mi mandi l'immagine a fmal@fmal.com?
Grazie
Socio AMI Piemonte

Avatar utente
Luca Baralis
Messaggi: 2882
Iscritto il: lun 06 set, 2004 18:55
Località: Torino
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Luca Baralis » dom 01 ott, 2017 21:10

Chrysanthemum.jpg
Immagine campione 1024x768
Questa invece è andata: si tratta di una delle immagini campione di windows 1024x768. Direi che il problema sta nelle immagini, ma sono immagini prodotte ec preparate per il forum nello stesso identico modo di sempre. Boh, :roll:
Luca (LB)
Socio AMI Piemonte

Avatar utente
Fulvio Malfatto
Site Admin
Messaggi: 722
Iscritto il: gio 24 giu, 2004 16:32
Località: Roppolo (BI) - Italy
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Fulvio Malfatto » dom 01 ott, 2017 21:28

IMG_0166r.jpg
Senza problemi... ma ho notato che quella ridotta ha una risoluzione diversa dall'originale, 96 vs 72. Non vorrei che l'algoritmo di interpolazione per aumentare la definizione abbia introdotto qualcosa che turba il browser durante la trasmissione. O banalmente che la cache sia corrotta...
L'immagine mi pare perfetta.
Comunque non ha senso aumentare oltre 72dpi la definizione di una immagine che deve essere visualizzata a video e non stampata.
Socio AMI Piemonte

Avatar utente
Massimo Russo
Messaggi: 6378
Iscritto il: mar 29 giu, 2004 12:00
Località: via Consalvo, 120/A, I-80125 Napoli
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Massimo Russo » dom 01 ott, 2017 21:39

Da iPhone so IOS. Senza problemi

Massimo
Allegati
image.jpg
---------------------------------------
Massimo Russo
INGV - Osservatorio Vesuviano

"Un minerale senza nome è solo un inutile pezzo di pietra" (Massimo Russo)

Avatar utente
Fulvio Malfatto
Site Admin
Messaggi: 722
Iscritto il: gio 24 giu, 2004 16:32
Località: Roppolo (BI) - Italy
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Fulvio Malfatto » dom 01 ott, 2017 22:10

Spiegato l'arcano: alcuni editor di immagini forniti di base col SO introducono un errore nelle dimensioni EXIF quando ridimensionano una immagine con cambio di definizione. Alcune vecchie versioni di browser ricavano le dimensioni dalle info EXIF e non ricalcolandole dalla immagine stessa.
Ecco le info EXIF della immagine originale e di quella ridotta da Luca. Le dimensioni di quella ridotta sono completamente sbagliate.
Cattura.JPG
Consiglio di ridurle con software di qualità o almeno con IrfanView, gratuito e potentissimo
Socio AMI Piemonte

Avatar utente
Luca Baralis
Messaggi: 2882
Iscritto il: lun 06 set, 2004 18:55
Località: Torino
Contatta:

Re: Prova inserimento foto x Paolo C.

Messaggio da Luca Baralis » lun 02 ott, 2017 0:06

Cambio di definizione, tra l'altro, non richiesto e impostato autonomamente dal software...
Mi chiedo se è una novità introdotta con aggiornamenti recenti, perchè in passato non avevo mai constatato simili problemi. Di recente abbiamo dovuto scegliere se disinstallare alcuni aggiornamenti di Ms-Office o imparare il portoghese...
Luca (LB)
Socio AMI Piemonte

Rispondi

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti